[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Guile-CV: Not a GRAY, RGB nor an RGBA image "sand.tif"

From: David Pirotte
Subject: Re: Guile-CV: Not a GRAY, RGB nor an RGBA image "sand.tif"
Date: Tue, 5 Dec 2017 19:55:40 -0200

Hi Daniele,

> > Yes: your are not in the right directory wrt guile, and this flename 'does 
> > not
> > exists', it does not exists in the directory your are trying to load this 
> > image,
> > see:
> >
> >         scheme@(guile-user)> (getcwd)
> >         $5 = "/usr/alto/projects/guile-cv/images"  
> unfortunately that's not the problem, I am in the right directory and
> the image is there. I still get that error.

This is impossible :), you think you are in the right directory, but you most
likely you are not.

You can try (getcwd), then (system "ls") and compare ...  till you are convinced
this is the source of your problem (or proved me wrong, then I'll pay you a 
pack of
beers :)

        unless you would have inadvertently replaced the file content with 
        else then a tif image... I very much doubt but just in case, you can run
        'file sand.tif' in a terminal and double check... if the file is not a 
        file, although it would be in the directory, the same error you be
        reported ...

Did you run 'make check' while you built guile-cv? Did all check pass? It checks
that im-load works fine ...


Attachment: pgpt6Ez_v7eRt.pgp
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]