[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Paparazzi-devel] Blank GCS with Lisa/S

From: beryl.wicaksono
Subject: Re: [Paparazzi-devel] Blank GCS with Lisa/S
Date: Mon, 2 Mar 2015 12:17:50 -0700 (MST)

Hi Garrosh,

Thank you for your reply. Actually, I also run paparazzi in ubuntu14.04
VMWare on Windows 7, and I have tried to my friend laptop that use a native
Linux install but I still facing the same problem. 

After I read your message, I have just re-bind. I thought that my bound was
1. Bind transmitter to usbrf --> I plug the usbrf, then press bind button,
the orange led is ON. Power ON my transmitter in bind mode, than the orange
led goes OFF and the red led goes ON. (Successful, right?).When I turn off
the transmitter, the red led goes OFF and then when I turn on again, the red
led goes ON.
2. Bind transmitter to Lisa/S --> turn ON lisa/s while pressing bind button,
then the outer orange led blink slowly. Turn ON my transmitter in bind mode.
The orange led blinks fast and then remains ON. (Successful, right?). When I
turn off the transmitter, the orange led blinks fast (it means that no
radios,doesn't it?). And when I turn on again the transmitter, the orange
led in Lisa/S blinks fast and then remains ON. So I thought that I was
successfully bound it.
(I did that (step 1 and 2) in different time)

When plug in the usbrf, turn on Lisa, and turn on the transmitter, the outer
orange led in Lisa/s goes ON and the two red leds in usbrf go ON,too. So I
think that Lisa/s has communicate with usbrf, and vice versa. So I execute
"Flight address@hidden" session. I surprised when I see the "Message"
window, that there was some downlink message. (This was never happened
before). But the GCS still showed a blank GCS with "Waiting for telemetry.."
message. and there was a message :
File ", line 523, character 4-10:Assertion failed

Here I attach my screen-shot when running this problem. 

So, what is your next idea? Thank you very much for helping me :D 

Garrosh wrote
> Hello Beryl,
> I have some experience with the Lisa/S and the usbrf. I've had the same
> problem you have now. I was facing several problems. I was attempting to
> run paparazzi on a virtual machine, and the VM I was using was having
> trouble letting my usb ports communicate through, and I thought that was
> the source of my problem. When I eventually reformated and went with a
> native Linux install, I was still facing the same problem, and this time,
> I
> thought it was because of the Black Magic Probe I was using, that was
> getting ACM0 allocated to it, while the usbrf fell over to ACM1. When I
> fixed that, my problem remained. I had already confirmed with a "dmesg |
> tail" that my usbrf was properly detected and my udev rules were properly
> setup.
> What ultimately fixed the problem was the binding procedure. When you plug
> in the usbrf and you want to bind it to your remote, you have to make sure
> that you're pressing the bind button on it. Ditto when you power on the
> Lisa/S. Don't try to bind them both at once, look at the flashing lights
> to
> make sure the binding occurs. If everything is properly communicating and
> the signal still doesn't get through the GCS, I still have a few more
> ideas, just let me know.
> Samuel Comeau
> _______________________________________________
> Paparazzi-devel mailing list

> Paparazzi-devel@


Beryl Wicaksono
Electrical Engineering
Bandung Institute of Technology
View this message in context:
Sent from the paparazzi-devel mailing list archive at

reply via email to

[Prev in Thread] Current Thread [Next in Thread]