[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Paparazzi-devel] Blank GCS with Lisa/S

From: beryl.wicaksono
Subject: Re: [Paparazzi-devel] Blank GCS with Lisa/S
Date: Tue, 3 Mar 2015 07:01:26 -0700 (MST)

Hi Sam,

I've tried to power up the the components in reverse order.  But it still
doesn't shows what I want. 
Before I reinstall my paparazzi center, I have a simulation session playing
with 3 airframes (LadyLisa, Qaud_LisaS, and Microjet), after that when I
changed the target became "ap" with Quad_LisaS airframe and upload it, the
GCS showed a "green link in telemetry" but with message "no link_id". 
Hopefully this problems end, but I think that it was like a history session
of my simulation.

So I re-install the paparazzi center. When I tried to upload the Quad_LisaS
airframe, the GCS shows blank screen. I don't understand why now the GCS
doesn't shows anything, and the telemetry doesn't connect.

Right, my Lisa/S is version 1.0

So I will try your next advice. How is the configuration to talk with Lisa
via BMP ?
FYI, I have flashed the superbit usb rf with some changes (see my post
above), so now I'm running in DSM2 protocol.
by the way, How to change the baudrate speed?

Thank your for your help



Garrosh wrote
> Hi Beryl,
> That is some good news! Yes, your bind was successful, and your messages
> means 
> that the signal is going through, and all of your hardware is fine, as far
> as I 
> know. What you can do next is change the order in which you power up your 
> components. Do it in the exact reverse order: first the transmitter, so
> both 
> the Lisa/S and the usbrf get powered on with a valid signal, then the
> Lisa, 
> and finally the usbrf. 
> If that still doesn't float your boat, check your paparazzi version, or
> more 
> specifically, the version of airframe you are using. Depending on the
> version 
> of paparazzi you're using, you may be using a version that has some
> outdated 
> airframe files relative to the code base. The Lisa/S is a fairly recent
> board, 
> and there as version 0.1 not that long ago (you are most likely using a 
> version 1.0). If the airframe seems legit, try an other airframe based off
> the 
> Lisa/S. I've personally never had any luck with ladybird, but did get some
> out 
> of the quadracopter. Just grep around, you'll find one that works.
> If you still have no luck with that, try talking with your Lisa/S through
> your 
> Black Magic Probe. You shouldn't have much trouble with that, especially
> if 
> you pay attention to which device your BMP gets listed as (since both the 
> usbrf and the BMP are ttyACM*).
> And if you still have no luck, then there are still things to try, like
> using 
> gdb to communicate with the code on the Lisa/S, flashing the usbrf,
> changing 
> the operating mode of the remote (DSMX or DSM2) or the baud rate of your 
> serial connection.
> Cheers!
> Sam
> On March 2, 2015 12:17:50 PM beryl.wicaksono wrote:
> _______________________________________________
> Paparazzi-devel mailing list

> Paparazzi-devel@


Beryl Wicaksono
Electrical Engineering
Bandung Institute of Technology
View this message in context:
Sent from the paparazzi-devel mailing list archive at

reply via email to

[Prev in Thread] Current Thread [Next in Thread]