qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH 09/10] accel/tcg: re-inline the filtering of virtual IRQs but


From: Philippe Mathieu-Daudé
Subject: Re: [PATCH 09/10] accel/tcg: re-inline the filtering of virtual IRQs but data driven
Date: Mon, 20 Mar 2023 15:58:22 +0100
User-agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:102.0) Gecko/20100101 Thunderbird/102.9.0

On 20/3/23 11:10, Alex Bennée wrote:
Although only I386 currently uses it it is not inconceivable that
other arches might find this facility useful.

Signed-off-by: Alex Bennée <alex.bennee@linaro.org>
---
  include/hw/core/tcg-cpu-ops.h |  5 +++++
  accel/tcg/cpu-exec.c          | 29 +++++++++--------------------
  target/i386/tcg/tcg-cpu.c     |  1 +
  3 files changed, 15 insertions(+), 20 deletions(-)

diff --git a/include/hw/core/tcg-cpu-ops.h b/include/hw/core/tcg-cpu-ops.h
index 66c0cecdde..8e8df8c330 100644
--- a/include/hw/core/tcg-cpu-ops.h
+++ b/include/hw/core/tcg-cpu-ops.h
@@ -121,6 +121,11 @@ struct TCGCPUOps {
       */
      bool (*io_recompile_replay_branch)(CPUState *cpu,
                                         const TranslationBlock *tb);
+    /**
+     * @virtual_interrupts: IRQs that can be ignored for replay purposes
+     */
+    int virtual_interrupts;

Maybe rename as "virtual_interrupts_mask" and use 'unsigned' type?



reply via email to

[Prev in Thread] Current Thread [Next in Thread]