[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [GNUe] Re: GNUe (was 'What's up?')

From: Adrian Maier
Subject: Re: [GNUe] Re: GNUe (was 'What's up?')
Date: Wed, 17 Mar 2004 14:39:11 +0200
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5b) Gecko/20030901 Thunderbird/0.2

Hello guys,

I have followed this thread with great interest. I am one of the newbies
who find gnue a great project, but haven't been able to actually use
it because of various reasons.

GNUe-Tools is promising, interesting, and cool. But, unfortunately,
i haven't been able to do anything functional with it (yet).
Since people are saying that they are using it , i guess that i
haven't succeeded simply because my lack of experience.

So far, my experience with gnue can be summed up like this:
- i have downloaded and installed it (0.5.2, and a few nightly snapshots),
- i have tried to do do some forms,
- encountered different problems (i haven't been able to solve them
- then put it "ON HOLD, until it gets more stable".

I guess we don't cover this well in the manuals as they go into building more complex forms :( I'll go thru a quick, quick step thru here. If someone needs more details just ask, i'll do what I can to provide them.

1. Install gnue-common, gnue-forms, gnue-designer and their dependencies
2. Edit connections.conf to setup entries for any database systems you are
3. Open gnue-designer. 4. File -> Save As (i'll save as zip.gfd)
5.  Exit designer
6.  gnue-forms zip.gfd
7. Your form should come up after login. Press <f8> then <f9> to have it load all data from the table. You can edit, delete, insert however you
    wish at this point.  You have a fully functional application.

When I had tried GNUe-Forms,  i had done exactly as you suggest now.
But I encountered different problems, for example:
- gnue-designer wasn't able to read the schema of the database
  ( changing the provider sometimes solved this problem, but I haven't
    found a provider that functions allways ).
- (when running the form) going to the last record in the result set
    never worked :  it raised an exception
- for date fields, it was not accepting the whole value: for example
    i could enter only "12.3" instead of "12.3.2004".
    If i remember correctly, it was setting the length to 4, so it
    was ignoring the keys entered after the first 4 characters.

I haven't tried the new 0.5.3 yet - maybe things have changed.

I think the main problem in my case is that I haven't found yet a place
where i could find solutions to the problems/difficulties that i might
encounter while writing applications.
The address@hidden mailing list is almost dead ( i had posted a message
some time ago and received absolutely no answer ).  And I have tried
to join the IRC channel 2-3 times, but I haven't chosen well the hour
and found nobody around.

What time are you guys connected to the IRC ? (my timezone is GMT+2).

Adrian Maier

reply via email to

[Prev in Thread] Current Thread [Next in Thread]